# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<name>([^<]+)<\/name>\s*<short>)\s*(<\/short>)/$1$2$3/g;t' <<< "Пример:
<category id=\"1\"><name>Мужские куртки</name><short></short></category>
<category id=\"2\"><name>Мужские брюки</name><short></short></category>
<category id=\"3\"><name>Мужские портянки</name><short></short></category>
Нужно:
<category id=\"1\"><name>Мужские куртки</name><short>Мужские куртки</short></category>
<category id=\"2\"><name>Мужские брюки</name><short>Мужские брюки</short></category>
<category id=\"3\"><name>Мужские портянки</name><short>Мужские портянки</short></category>"