#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<name>([^<]+)</name>\s*<short>)\s*(</short>)"
Local $sString = "Пример:" & @CRLF & _
"" & @CRLF & _
"<category id="1"><name>Мужские куртки</name><short></short></category>" & @CRLF & _
"<category id="2"><name>Мужские брюки</name><short></short></category>" & @CRLF & _
"<category id="3"><name>Мужские портянки</name><short></short></category>" & @CRLF & _
"" & @CRLF & _
"Нужно:" & @CRLF & _
"" & @CRLF & _
"<category id="1"><name>Мужские куртки</name><short>Мужские куртки</short></category>" & @CRLF & _
"<category id="2"><name>Мужские брюки</name><short>Мужские брюки</short></category>" & @CRLF & _
"<category id="3"><name>Мужские портянки</name><short>Мужские портянки</short></category>"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)