package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<name>([^<]+)</name>\s*<short>)\s*(</short>)`)
var str = `Пример:
<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>
Нужно:
<category id="1"><name>Мужские куртки</name><short>Мужские куртки</short></category>
<category id="2"><name>Мужские брюки</name><short>Мужские брюки</short></category>
<category id="3"><name>Мужские портянки</name><short>Мужские портянки</short></category>`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}