// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<name>([^<]+)</name>\s*<short>)\s*(</short>)").unwrap();
let string = "Пример:
<category id=\"1\"><name>Мужские куртки</name><short></short></category>
<category id=\"2\"><name>Мужские брюки</name><short></short></category>
<category id=\"3\"><name>Мужские портянки</name><short></short></category>
Нужно:
<category id=\"1\"><name>Мужские куртки</name><short>Мужские куртки</short></category>
<category id=\"2\"><name>Мужские брюки</name><short>Мужские брюки</short></category>
<category id=\"3\"><name>Мужские портянки</name><short>Мужские портянки</short></category>";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}