#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)["':;^!+\-()\[\]\\{}\/<>,.#&$]([0-9a-zA-Z]+~[0-9a-zA-Z]+\.[0-9a-zA-Z]+)['":;^!+\-()\[\]\\{}\/<>,.#&$]"
Local $sString = "'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa'" & @CRLF & _
""b2~b2.bb) тут текст "b2~b2.bb) тут текст "b2~b2.bb) " & @CRLF & _
"c1~c3.cc тут текст c1~c3.cc тут текст"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")