re = /["':;^!+\-()\[\]\\{}\/<>,.#&$]([0-9a-zA-Z]+~[0-9a-zA-Z]+\.[0-9a-zA-Z]+)['":;^!+\-()\[\]\\{}\/<>,.#&$]/m
str = '\'a1~a1.aa\' тут текст \'a1~a1.aa\' тут текст \'a1~a1.aa\' тут текст \'a1~a1.aa\'
"b2~b2.bb) тут текст "b2~b2.bb) тут текст "b2~b2.bb)
c1~c3.cc тут текст c1~c3.cc тут текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end