import re
regex = re.compile(r"[\"':;^!+\-()\[\]\\{}\/<>,.#&$]([0-9a-zA-Z]+~[0-9a-zA-Z]+\.[0-9a-zA-Z]+)['\":;^!+\-()\[\]\\{}\/<>,.#&$]", flags=re.MULTILINE)
test_str = ("'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa'\n"
"\"b2~b2.bb) тут текст \"b2~b2.bb) тут текст \"b2~b2.bb) \n"
"c1~c3.cc тут текст c1~c3.cc тут текст")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")