using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""':;^!+\-()\[\]\\{}\/<>,.#&$]([0-9a-zA-Z]+~[0-9a-zA-Z]+\.[0-9a-zA-Z]+)['"":;^!+\-()\[\]\\{}\/<>,.#&$]";
string input = @"'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa' тут текст 'a1~a1.aa'
""b2~b2.bb) тут текст ""b2~b2.bb) тут текст ""b2~b2.bb)
c1~c3.cc тут текст c1~c3.cc тут текст";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}