$re = '/["\':;^!+\-()\[\]\\\\{}\/<>,.#&$]([0-9a-zA-Z]+~[0-9a-zA-Z]+\.[0-9a-zA-Z]+)[\'":;^!+\-()\[\]\\\\{}\/<>,.#&$]/m';
$str = '\'a1~a1.aa\' тут текст \'a1~a1.aa\' тут текст \'a1~a1.aa\' тут текст \'a1~a1.aa\'
"b2~b2.bb) тут текст "b2~b2.bb) тут текст "b2~b2.bb)
c1~c3.cc тут текст c1~c3.cc тут текст';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);