using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(((?:[^\(\)]++|(?R))*)\)";
string input = @"a(bc)de(fg)h
a(bcd(ef)g)h
a(bcd(e(f(g(h)))))ij(kl)n(o(qr)p)(s)(tuvw)(((x)y)z)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}