package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(((?:[^\(\)]++|(?R))*)\)`)
var str = `a(bc)de(fg)h
a(bcd(ef)g)h
a(bcd(e(f(g(h)))))ij(kl)n(o(qr)p)(s)(tuvw)(((x)y)z)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}