// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(((?:[^\(\)]++|(?R))*)\)").unwrap();
let string = "a(bc)de(fg)h
a(bcd(ef)g)h
a(bcd(e(f(g(h)))))ij(kl)n(o(qr)p)(s)(tuvw)(((x)y)z)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}