use strict;
my $str = 'a(bc)de(fg)h
a(bcd(ef)g)h
a(bcd(e(f(g(h)))))ij(kl)n(o(qr)p)(s)(tuvw)(((x)y)z)';
my $regex = qr/\(((?:[^\(\)]++|(?R))*)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}