$re = '/\(((?:[^\(\)]++|(?R))*)\)/';
$str = 'a(bc)de(fg)h
a(bcd(ef)g)h
a(bcd(e(f(g(h)))))ij(kl)n(o(qr)p)(s)(tuvw)(((x)y)z)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);