#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d?\s?\(?\d{3}\)?[\s-]{0,1}\d{3}[\s-]{0,1}\d{4}$"
Local $sString = "555-555-5555" & @CRLF & _
"(555)555-5555" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"555 555 5555" & @CRLF & _
"5555555555" & @CRLF & _
"1 555 555 5555" & @CRLF & _
"" & @CRLF & _
"1 555)555-5555" & @CRLF & _
"(6054756961)" & @CRLF & _
"-1 (757) 622-7382" & @CRLF & _
"555)-555-5555" & @CRLF & _
"(555-555-5555" & @CRLF & _
"(555)5(55?)-5555" & @CRLF & _
"55 55-55-555-5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")