using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d?\s?\(?\d{3}\)?[\s-]{0,1}\d{3}[\s-]{0,1}\d{4}$";
string input = @"555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 555)555-5555
(6054756961)
-1 (757) 622-7382
555)-555-5555
(555-555-5555
(555)5(55?)-5555
55 55-55-555-5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}