package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d?\s?\(?\d{3}\)?[\s-]{0,1}\d{3}[\s-]{0,1}\d{4}$`)
var str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 555)555-5555
(6054756961)
-1 (757) 622-7382
555)-555-5555
(555-555-5555
(555)5(55?)-5555
55 55-55-555-5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}