const regex = /^\d?\s?\(?\d{3}\)?[\s-]{0,1}\d{3}[\s-]{0,1}\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d?\\s?\\(?\\d{3}\\)?[\\s-]{0,1}\\d{3}[\\s-]{0,1}\\d{4}$', 'gm')
const str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 555)555-5555
(6054756961)
-1 (757) 622-7382
555)-555-5555
(555-555-5555
(555)5(55?)-5555
55 55-55-555-5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}