# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d?\s?\(?\d{3}\)?[\s-]{0,1}\d{3}[\s-]{0,1}\d{4}$"
test_str = ("555-555-5555\n"
"(555)555-5555\n"
"(555) 555-5555\n"
"555 555 5555\n"
"5555555555\n"
"1 555 555 5555\n\n"
"1 555)555-5555\n"
"(6054756961)\n"
"-1 (757) 622-7382\n"
"555)-555-5555\n"
"(555-555-5555\n"
"(555)5(55?)-5555\n"
"55 55-55-555-5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.