# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(?(\d{3})\)?[ -.]?(\d{3})[ -.]?(\d{4})/(\1)\2-\3/g;t' <<< "(123)456-7890 (321)-654-0987
(111) 111-1111
222-222-2222
(333)333.3333
(444).444.4444
blah blah blah (555) 555.5555
666.666.6666 random text"