using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(?(\d{3})\)?[ -.]?(\d{3})[ -.]?(\d{4})";
string substitution = @"(\1)\2-\3";
string input = @"(123)456-7890 (321)-654-0987
(111) 111-1111
222-222-2222
(333)333.3333
(444).444.4444
blah blah blah (555) 555.5555
666.666.6666 random text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}