#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(?(\d{3})\)?[ -.]?(\d{3})[ -.]?(\d{4})"
Local $sString = "(123)456-7890 (321)-654-0987" & @CRLF & _
"(111) 111-1111" & @CRLF & _
"222-222-2222" & @CRLF & _
"(333)333.3333" & @CRLF & _
"(444).444.4444" & @CRLF & _
"blah blah blah (555) 555.5555" & @CRLF & _
"666.666.6666 random text"
Local $sSubst = "(\1)\2-\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)