# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(?(\d{3})\)?[ -.]?(\d{3})[ -.]?(\d{4})"
test_str = ("(123)456-7890 (321)-654-0987\n"
"(111) 111-1111\n"
"222-222-2222\n"
"(333)333.3333\n"
"(444).444.4444\n"
"blah blah blah (555) 555.5555\n"
"666.666.6666 random text")
subst = "(\\1)\\2-\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.