import Foundation
let pattern = #"\(?(\d{3})\)?[ -.]?(\d{3})[ -.]?(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(123)456-7890 (321)-654-0987
(111) 111-1111
222-222-2222
(333)333.3333
(444).444.4444
blah blah blah (555) 555.5555
666.666.6666 random text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1)\2-\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)