#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([/#]?[A-Za-z0-9$]+)[/_].*"
Local $sString = "#Tableau_6_sid:15251a_4i_2a" & @CRLF & _
"/15722c29d_PhotoImageCameraPro" & @CRLF & _
"JAVA/15722c29d_PhotoImageqeeee" & @CRLF & _
"ABC_CUST_INFO_D" & @CRLF & _
"BBC_CUST_ENTRY_F" & @CRLF & _
"FHS_PRDCT_STST_T" & @CRLF & _
"GHS_INVTR_CD_DRY"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)