import Foundation
let pattern = ##"^([/#]?[A-Za-z0-9$]+)[/_].*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)