import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([/#]?[A-Za-z0-9$]+)[/_].*";
final String string = "#Tableau_6_sid:15251a_4i_2a\n"
+ "/15722c29d_PhotoImageCameraPro\n"
+ "JAVA/15722c29d_PhotoImageqeeee\n"
+ "ABC_CUST_INFO_D\n"
+ "BBC_CUST_ENTRY_F\n"
+ "FHS_PRDCT_STST_T\n"
+ "GHS_INVTR_CD_DRY";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}