// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([/#]?[A-Za-z0-9$]+)[/_].*").unwrap();
let string = "#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}