package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:^|[^\\])(?:\\\\)*\$([^\\$]*(?:\\[\w\W][^\\$]*)*)\$`)
var str = `$ some test here$
$ some text here with inner \$ $
\$ this should not be matched\$
text before $match here$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}