$re = '/(?:^|[^\\\\])(?:\\\\\\\\)*\$([^\\\\$]*(?:\\\\[\w\W][^\\\\$]*)*)\$/mi';
$str = '$ some test here$
$ some text here with inner \\$ $
\\$ this should not be matched\\$
text before $match here$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);