// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:^|[^\\])(?:\\\\)*\$([^\\$]*(?:\\[\w\W][^\\$]*)*)\$").unwrap();
let string = "$ some test here$
$ some text here with inner \\$ $
\\$ this should not be matched\\$
text before $match here$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}