import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^\\\\])(?:\\\\\\\\)*\\$([^\\\\$]*(?:\\\\[\\w\\W][^\\\\$]*)*)\\$";
final String string = "$ some test here$\n"
+ "$ some text here with inner \\$ $\n"
+ "\\$ this should not be matched\\$\n\n"
+ "text before $match here$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}