re = /(?:^|[^\\])(?:\\\\)*\$([^\\$]*(?:\\[\w\W][^\\$]*)*)\$/mi
str = '$ some test here$
$ some text here with inner \\$ $
\\$ this should not be matched\\$
text before $match here$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end