#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{2} \d{3} \d{3} \d{3}\b|\b\d{11}\b|\b\d{2} \d{6} \d{3}\b|\b\d{8} \d{3}\b|\b\d{2} \d{4} \d{5}\b|\b\d{2} \d{9}\b"
Local $sString = "12 345 678 901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")