use strict;
my $str = '12 345 678 901';
my $regex = qr/\b\d{2} \d{3} \d{3} \d{3}\b|\b\d{11}\b|\b\d{2} \d{6} \d{3}\b|\b\d{8} \d{3}\b|\b\d{2} \d{4} \d{5}\b|\b\d{2} \d{9}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}