package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{2} \d{3} \d{3} \d{3}\b|\b\d{11}\b|\b\d{2} \d{6} \d{3}\b|\b\d{8} \d{3}\b|\b\d{2} \d{4} \d{5}\b|\b\d{2} \d{9}\b`)
var str = `12 345 678 901`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}