re = /\b\d{2} \d{3} \d{3} \d{3}\b|\b\d{11}\b|\b\d{2} \d{6} \d{3}\b|\b\d{8} \d{3}\b|\b\d{2} \d{4} \d{5}\b|\b\d{2} \d{9}\b/m
str = '12 345 678 901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end