#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[_.!@$*=-?])[^%&+\\\s"]{6,15}$"
Local $sString = "Abc123@" & @CRLF & _
"abc123@" & @CRLF & _
"ABC123@" & @CRLF & _
"Abc1234" & @CRLF & _
"Abc123@aaaaaaaa" & @CRLF & _
"Abc123@aaaaaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")