$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[_.!@$*=-?])[^%&+\\\\\s"]{6,15}$/m';
$str = 'Abc123@
abc123@
ABC123@
Abc1234
Abc123@aaaaaaaa
Abc123@aaaaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);