const regex = /^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[_.!@$*=-?])[^%&+\\\s"]{6,15}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)(?=.*[_.!@$*=-?])[^%&+\\\\\\s"]{6,15}$', 'gm')
const str = `Abc123@
abc123@
ABC123@
Abc1234
Abc123@aaaaaaaa
Abc123@aaaaaaaaa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}