import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)(?=.*[_.!@$*=-?])[^%&+\\\\\\s\"]{6,15}$";
final String string = "Abc123@\n"
+ "abc123@\n"
+ "ABC123@\n"
+ "Abc1234\n"
+ "Abc123@aaaaaaaa\n"
+ "Abc123@aaaaaaaaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}