using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[_.!@$*=-?])[^%&+\\\s""]{6,15}$";
string input = @"Abc123@
abc123@
ABC123@
Abc1234
Abc123@aaaaaaaa
Abc123@aaaaaaaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}