#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\S+ \S+$"
Local $sString = "word word" & @CRLF & _
"word word word" & @CRLF & _
"word word word word" & @CRLF & _
"word" & @CRLF & _
"a a" & @CRLF & _
"a a a" & @CRLF & _
"b b" & @CRLF & _
"b b b" & @CRLF & _
"FOO BAR" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"a " & @CRLF & _
"b " & @CRLF & _
"c " & @CRLF & _
"d d" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")