re = /^\S+ \S+$/m
str = 'word word
word word word
word word word word
word
a a
a a a
b b
b b b
FOO BAR
a
b
c
d d
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end