$re = '/^\S+ \S+$/m';
$str = 'word word
word word word
word word word word
word
a a
a a a
b b
b b b
FOO BAR
a
b
c
d d
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);