import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\S+ \\S+$";
final String string = "word word\n"
+ "word word word\n"
+ "word word word word\n"
+ "word\n"
+ "a a\n"
+ "a a a\n"
+ "b b\n"
+ "b b b\n"
+ "FOO BAR\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "a \n"
+ "b \n"
+ "c \n"
+ "d d\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}