# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\\/|\?.*$//gm;t' <<< "www.website.com/dsw/fv3n24nv1e4121v/123456789012?fwe=32432fdwe23f3"