// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\/|\?.*$").unwrap();
let string = "www.website.com/dsw/fv3n24nv1e4121v/123456789012?fwe=32432fdwe23f3";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}