$re = '/^.*\/|\?.*$/m';
$str = 'www.website.com/dsw/fv3n24nv1e4121v/123456789012?fwe=32432fdwe23f3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;