use strict;
my $str = 'www.website.com/dsw/fv3n24nv1e4121v/123456789012?fwe=32432fdwe23f3';
my $regex = qr/^.*\/|\?.*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";